Jump to content

Search the Community

Showing results for tags 'ignition'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to CT Flier!
    • Forum News and Info
    • Polls
  • CT General Discussion
    • CT in the News
    • CT Announcements and Bulletins
    • Landing and Flying
    • Flight Instruction
    • Spot Tracker Member Links.
    • Light Sport/Sport Pilot
    • Flight Planning & Weax
    • Fly-Ins
    • Incidents
    • For Sale/Want to Buy
    • Random Thoughts
    • Trip Reports
    • Video
  • Avionics
    • General Avionics
    • Radios
    • GPS
    • Panels & Controls
    • ELT/Transponders
    • Panel & Controls
    • EFBs
    • Autopilot/Traffic Watch
    • Accessories, etc.
  • Maintenance (Remember to Work smart, Not hard)
    • General Maintenance
    • Engine/Rotax
    • Airframe/Exterior/Interior
    • Maintenance Technicians .... Anywhere in the world!
    • Maintenance Pictures and Videos
    • Fuels & Fluids
  • Dealer Forums: ....Aircraft for Sale, ....Services,.... Events,....Specials
    • Flight Design USA
    • Airtime Aviation
    • Lone Mountain Aviation
    • Premier One Aviation
    • Sonoma Flight Center

Categories

  • Manuals
  • Other Downloads

Calendars

  • Community Calendar

Blogs

  • Admin Blog
  • Roger's Blog
  • Admin2's Blog
  • Safety Officer's Blog

Found 3 results

  1. Starts but won't STOP !? (CT2K)

    After doing a bunch of maintenance work (replacing the LargeEngineFrame (old one bent & cracked), 5yr Rubber replacement, Firewall heat-shielding, new FuelPump, Header-wrap, etc) I did an oil purge, checked valve tappets and it starts and runs beautifully on 1&2. At about 3000rpm, get a drop of 150rpm when switched to ignition 2, but when switched to ignition 1, the rpm goes back UP to same as 1&2 ! Turn to "off" and the engine keeps running ! (FlyDat goes blank but the engine keeps running smoothly) Have gone over the earthing points and cleaned all the surfaces with emery paper - no change. The Ignition Modules are the older style, 4-pin connector types.. Any thoughts greatly appreciated. David Merry Christmas and Happy New Year.
  2. Just would like to add my inputs on Rotax no start from this side of the Atlantic. My CTSW/100 ps Rotax/2007/800 hours has refuses to start for 2 weeks, not even a small evidence that, at least, sparks plug got something. Listening mechanical and other friends, I tried: - looking at a Spark on spark plug: nothing, even on a dark room. - recharge the battery: not better. - check the fuel if any contamination in the filter, or in the bowl carb: nothing (bowl full, no water, no contamination) - checking ignition key if on 1+2 position is not grounded: Ok - checking impedance from all generator coil: Ok( I compare it with an other Rotax dismounted) - replace the Regulator by a new one: no improvement. - check grounding connection: nothing was looking bad. Finnaly, one person in a shop give me this adivce: with all your test, your engine should work! Stop to touch everything, set your engine in best condition for a good start, and try again. So, back to the airfield and it finnaly starts with the following: - listen Roger witch is strongly pushing on grounding: I have clean and tight all grounding bolt. Changed the one with spot of corrosion. -fully charge the battery again (with an advanced digital charger) 3 A/H was missing. - replace all spark plus by new ones (not done on the last 200 hours) - let run some fuel out. -ignition for 10 s.: nothing (bowl carb. Were empty) - try #2: almost started! (large smile) - try #3: started : flew arround the pattern (on safe altitude): everything worked fine to allow nice local flight in Burgundy) Conclusion: -read and execute Roger's advices! Thanks again for your inputs: no one got your level here! Engine did not start due to a component failure, but due to the addition of several "weakeness" as battery partially discharge, old spark plugs, high air temperature, some grounding not 100% perfect and probably poor fuel quality. Hope this helps....
  3. Ignition Modules

    I'm trying to source a wiring diagram for installing the ignition modules from a 2007 ctsw on an earlier model. These modules have two 6 pin plugs, one male and the other female without the red lead to the off switch. I.m sure I've seen the diagrams somewhere in the manuals so any help in the right direction would be appreciated. Mac
×