Jump to content
SantaPaulaCTSW

Radio background noise - SL40

Recommended Posts

Hi Was flying the other day and started getting a background hollow sound in my headset during radio calls when pushing the push to talk button. It is a Garmin SL40. The

noise is heard in both the pilot and passenger headsets. I did a radio check in the air and on the ground, and my transmissions are being heard clearly, although one person said they were hearing some noise in the background too. I am hearing other airplane transmissions without this added noise. Just this irritating background noise when I transmit. Tried the squelch, but did not make a difference. Any suggestions are welcome! Thanks!

 

Robin

Share this post


Link to post
Share on other sites

The SL40 was supposed to be sent in a few years back to have this issue of superfluous noise taken care of. It was free back then, but you may have to pay now. Call Garmin and ask them.

Share this post


Link to post
Share on other sites

... Standard procedure for radios, and almost anything electrical on the CT... Check and really tighten all grounds!

Share this post


Link to post
Share on other sites

If you send anything to garmin, make sure you document every single problem you have with it. It's a flat rate repair.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×