Jump to content
Sign in to follow this  
JLang

Dynon D100 Dimming

Recommended Posts

The last few flights my D100 screen has had brightness issues.  At startup it is very dim, barely discernible.  It slowly get brighter and after maybe 10min is 80% as bright as the D120 on the right (both set to default max brightness, no autodim), which is readable but not ideal in bright sunlight.  Then at some point during the flight, it starts to dim to barely readable and then back to "full" bright, about once a second.  This slow flicker may last the flight, or stops and reverts to "full" (80%) bright.  I plan to pull the unit and check connections.  I did a quick check of Dynon support forum but didn't see anything.  I'm guessing the LED backlight circuitry is bad and it's not an easy fix, though I'm hoping if the LEDs die the unit will still send info to the D120.  Common problem?

Share this post


Link to post
Share on other sites

I had my very old D100  that took many minutes to start up (blank screen initially on powerup)   It started at a few mins to get the display and eventually 30 mins or more !!!   Not exactly the same as your description but perhaps a similar issue.   Sent it in to Dynon for repair and it works fine now.   I did inquire but i never got the explanation as to the cause - and i probably would not have understood any technical info anyways haha.   

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...