Jump to content
Big Flapper

Curious flap displays

Recommended Posts

On my "New" CTLS while on the ground when I put the flap setting to -6 I hear the flap motor running and then stop but the numbers still blink and the red light on the upper right of the display is on. This also happens on the 35 deg setting. Looking at the maintenance manual this looks like a control rod out of adjustment to me. Just want to confirm this before I dig into the airplane and make some adjustments.

Share this post


Link to post
Share on other sites

It can do that if you are at low rpms with low voltage with all your electronics on. Rev the engine up to 3000 rpm and see if it still does it.

Share this post


Link to post
Share on other sites

Did 6 cycles all settings except -6 and 35 worked fine, numbers stopped flashing when flaps reached the assigned angle. on -6 the upper red light is on and the number continues to flash even though the flap motor has stopped. Same for the 35 setting except that the lower red light is on.  Voltage is 12.9  Seems like the limit switches are stopping the flap motor before it reached the flap setting.

Share this post


Link to post
Share on other sites

Try reprogramming before you do anything.  One failed start or low battery dip seems to throw my flap computer out of whack.  Solved by replacing the battery and I keep it on a trickle charger.  I have a thread on here about reprogramming.  I hope it fixes it.

 

Bob

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...